Akkuanzeige in 1% schritten! Akkuanzeige in 1% schritten!
Ergebnis 1 bis 12 von 12
  1. Unregistriert Gast
    Hallo an Alle!
    Ist es möglich die Akkuanzeige mit hilfe eines Tools oder in der Registry
    so umzustellen, das die Anzeige 1% schritte macht!
    Ich finde diese 10% schritte sehr ungenau bin über jede Hilfe dankbar!

    Gruß
    0
     

  2. Hallo erstmal, elf threads weiter unten hättest du diesen hier gefunden:
    http://www.pocketpc.ch/se-xperia-x1/...xperia-x1.html
    0
     

  3. Unregistriert Gast
    Hallo,
    Ja diese Anzeige hatte und habe ich installiert!
    Bekomme aber immer noch nur 10% Schritte, ein Bekannter mit Touch pro hat mit dieser cab die 1% Schritte bekommen!
    Bei mir aufm X1 geht es aber nicht!
    Das ist ja mein Problem!

    Gruß
    0
     

  4. Unregistriert Gast
    vielleicht mal den gesamten thread lesen?? schaggo hat weiter unten erklärt wie man es genau machen muss. wenn dus so machst gehts auch
    0
     

  5. Unregistriert Gast
    Also ich habs jetzt nochmal genau so gemacht wie hier

    http://www.pocketpc.ch/se-xperia-x1/...xperia-x1.html

    beschrieben! Bekomme aber wie gesagt nur die 10% schritte angezeigt oder mein akku hat jetzt die ganze Zeit schon 60% kann ja aber auch nicht sein!
    Oder ich bin zu doof für die sache!
    Kann jemand mit einem X1 bestätigen, daß es bei ihm in 1% schritten zählt!

    Gruß
    0
     

  6. Die Akkuanzeige ist nichts anderes, als Bildchen, die aus einer DLL-Datei gelesen werden.
    Die "Auflösung", also wie viele Bildchen über die Strecke von 0% bis 100% geladen werden, gibt man in der Registry an. Logischerweise muss der Inhalt der DLL mit den Anzahl Schritten übereinstimmen.

    FUCKING ELENDER INTERNET EXPLORER 8!!! WENN ICH DEN BEITRAG ABSCHICKEN WOLLTE, HÄTTE ICH DAS AUCH GEMACHT!!! "ENTER" BEDEUTET ZEILENWECHSEL UND NICHT ABSCHICKEN DU W98/)*=(/*"!!!

    Nun, wo war ich? Ah, genau. Von Haus aus beherrbergt die DLL etwa 7 Symbole, 4 für Akku 100%, 75%, 50%, 25%, dann 1 für Akku mit Ausrufezeichen, ich glaube ebenfalls noch 1 für Akku mit Ausrufezeichen in Rot, und als 7. noch der Akku mit dem Ladestecker. Das Intervall für das Entladen ist 25%, entsprechend die 4 Bilchen.
    Die CAB-Datei aus dem anderen Thread installiert, wenns mir recht ist, eine DLL mit ~10 Bildchen für den Entladevorgang; ein Akkusymbol mit jeweils einer Zahl obendran. Zusätzlich wird mit der Registry das Intervall von 25% auf 10% geändert.
    Wenn du nun in der Registry einfach das Intervall änderst, ändert sich sonst gar nix, denn es sind nachwievor nur 10 Bildchen mit jeweils 100%, 90%, 80% etc vorhanden. Denn die %-Werte sind nicht errechnet, sondern die sind da hingezeichnet, das sind Bilder, keine Text-Strings oder so.

    Willst du also 1%-Schritte, brauchst du eine DLL in der alle einhundert Entladeschritte enthalten sind, zudem musst du das Intervall noch zu 1% ändern, damit alle Bilder der Reihe nach geladen werden. Ob sich jemand diese Mühe gemahct hat, weiss ich nicht, musst du selber recherchieren. Was ich aber vermute, dein Kumpel mit dem Touch Pro gemacht hat: nicht die DLL-Variante über sozusagen Windows Mobile-Boardmittel sondern ein Zusatztool, welches das Akkusymbol mit einem eigenen Symbol überdeckt und dort den Ladezustand in 1%-Schritten anzeigt. Gibt es glaube ich sogar gleich mehrere Möglichkeiten resp. Tools, die das machtn. Ist er aber auch über die DLL-Variante, kannst ganz einfach seine DLL nehmen, auf dem X1 ersetzen und das Intervall gemäss seinen Werten ändern, dann bist du ganz haargenau gleich wie er unterwegs. Wenn er behauptet, die CAB aus dem Beitrag oben genommen zu haben und 1%-Schritte erhalten zu haben, dann verzapft er nen Haufen Mist, weil der Inhalt der Daten in einem Resourcen-Editor angeguckt werden kann und keine 1%-Schritte drin sind, sondern 10%... Irrtum vorbehalten.
    Geändert von schaggo (30.11.2008 um 19:15 Uhr)
    0
     

  7. Ok, habe den Inhalt der CAB wie auch der ZIP in der ZIP drin analysiert.
    Sind beide genau das gleiche, die CAB automatisiert einfach, was in der ZIP drin ist. Sprich Dateiinhalt ist identisch. Ich lag oben falsch, Entschuldigung an dieser Stelle, die DLL hat tatsächlich alle Abstufungen von 100% bis 1% in Einzelschritten!

    Interessant ist allerdings, dass das REG-File in der ZIP andere Werte in die Registry einträgt als das Script in der CAB-Datei. Während Die CAB Dezimalwerte in die Registry schreibt, hinterlässt die REG-Datei ihre Spuren im hexadezimalen Format. Folgende Möglichkeiten: stell den Urzustand wieder her, indem du die CAB deinstallierst, die DLL-Datei löscht (phcanOverbmp.dll) und manuell die Registry auf die Ursprungswerte setzt:
    Code:
    [HKEY_LOCAL_MACHINE\security\ResOver\Bitmaps]
    "BaseDll"="phcanOverbmp.dll"
    "BaseId"=dword:0
    (d.h. BatteryIconLevels und BatteryIconIdStart löschen)
    Dann ein Softreset und dann installier einmal die CAB-Datei. Nach einem Softreset guck, was sich ergibt. Tut es nicht, dann importier die REG-Datei aus der ZIP und kontrollier, ob sich die Werte verändert haben (BatteryIconLevels statt Hex 65, Dec 101 BatteryIconIdStart statt Hex 3E9, Dec 1001). Dann Softreset und gucken, wie es sich jetzt verhält. Tut es immer noch nicht, scheint das X1 den Wert tatsächlich nur in 10% Schritten auszulesen.

    Jetzt mal davon abgesehen: Welchen wirklichen Nutzen bringen dir 1% Schritte? Ganz ganz ehrlich, 25% reicht doch eigentlich vollends, oder?
    Geändert von schaggo (30.11.2008 um 20:05 Uhr)
    0
     

  8. Hallo,

    so nachdem schaggo sich die ganze Mühe gemacht hat das zusammen zu schreiben habe ich es ausprobiert (Obwil ich nihct wirklich einen 1% Schritt benötige)

    Alles durchgemacht und in der Registry nachgesehen:

    BatteryIconLevels: Value data 101 Decimal
    BatteryIconIdStart: Value data 1001 Decimal

    Trotzdem wird nur in 10% Schritten angezeigt...es sei denn, ich ahb grad wirklich genau 70% ...werd in den nächsten Stunden bzw. Morgen nochmals nachsehen

    Grüße
    Martissimo
    0
     

  9. Unregistriert Gast
    Hallo und Danke für die Mühe!

    Ich werde das ganze mal wieder runtermachen und dann nochmal von vorne!
    Hoffe das es dann geht!

    Die 1% Schritte finde ich schon gut denn es macht ja einen Unterschied ob 14,9% denke er zeigt dann 10% oder 5% immer noch 10% Akku!
    Mit 14,9% geht es noch locker einen Tag mit 5% lade ich lieber den Akku bevor ich das Haus verlasse.

    Gruß
    0
     

  10. 15% noch 1 Tag...?!
    Ok, dann versteh ich das mit den 1%-Schritten. Wie ich in anderen Threads verlauten lassen hab: wenn ich das Gerät normal nutze, schaff ich von ca 07:00 bis 19:00 50% aus dem Akku zu saugen, wenn ich es intensiv nutze, muss ich am frühen Nachmittag bei 10% aufhören, da ich sonst den Rest des Tages nicht mehr mobil erreichbar wär... Bei 15% käm ich also am Morgen so ungefähr bis zur Treppe vor dem Haus und könnte dann wieder umkehren

    Besten Dank fürs Testen martissimo. Ich brauch nebenbei das System Info Tool, das beim Resco Explorer dabei ist. Und genau in dem Moment kommt es mir vor, als hätte ich da auch noch nie etwas anderes wie 10-er Werte gesehen, würde deine Beobachtung bestätigen... Hmmm... Kann das X1 tatsächlich nur in 10%-Schritten auslesen?

    Noch eine Anmerkung: in der Standardkonfiguration zeigt das X1 von 25% bis 10% noch 1 Balken, ab 10% zeigt es die Batterie mit einem Ausrufezeichen nebendran. Und ich bin mir nicht ganz sicher, aber ab 5% das ganze in roter Farbe. Irgendwann unter 5% deaktiviert sich dann glaube ich die Telefoneinheit und wenn der Akku leer ist, fährt das Gerät ganz runter.
    Geändert von schaggo (30.11.2008 um 23:04 Uhr)
    0
     

  11. Hallo,

    @schaggo: gar kein Problem.... bin leider nicht früher dazu gekommen...also derzeit ist das X1 bei 30%...also definitiv nur in 10% Schritten.

    Hab deine Datein verwesdnet sowie auh die von den Dev´s...bin also deine Schritte komplett durchgegangen, dann Hardreset und die gleichen Schritte wie bei den Dev´s beschrieben. Kein Erfolg.

    Falls ich noch was austesten soll bin ich gerne Bereit....

    Grüße
    Martissimo
    0
     

  12. Dave Bowman Gast
    Also, das finde ich schon ein wenig blöd. Kann ich nicht verstehen. Ich habe derzeit 10% stehen und frage mich, sind's 14 oder 6? Macht schon einen Unterschied. Wenn die alten Kisten wie das Kaiser (trotz allem nach wie vor ein tolles Teil) den Batteriestand selbstverständlich in Einer-Schritten darstellen, kapiere ich es nicht, wenn es Geräte wie das Xperia nicht machen. Hoffe da schwer auf das nächste Firmware-Update.

    Dave
    0
     

Ähnliche Themen

  1. Akkuanzeige zeigt immer "voll" an
    Von HomeboyST im Forum HTC Touch Pro
    Antworten: 4
    Letzter Beitrag: 20.10.2008, 11:45
  2. Aktuallisierung Akkuanzeige
    Von sebi88 im Forum HTC Touch Pro
    Antworten: 11
    Letzter Beitrag: 22.09.2008, 19:37
  3. Akkuanzeige - Problem
    Von Unregistriert im Forum HTC Touch Diamond
    Antworten: 9
    Letzter Beitrag: 19.09.2008, 11:42
  4. Akkuanzeige HTC
    Von Unregistriert im Forum HTC TyTN II
    Antworten: 8
    Letzter Beitrag: 28.07.2008, 19:50

Besucher haben diese Seite mit folgenden Suchbegriffen gefunden:

phcanoverbmp.dll

Battery Icon bei WM zeigt immer 100 an

windows 7 akku anzeige regedit

xperia x1 batteriestatus 1

xperia akku ansicht

xperia p akkuanzeige

Akkuanzeige x1

xperia x8 akkuanzeige

xperia x8 akku anzeige

energieanzeige xp 10

Batteriestatus xperia ray

windows mobile 6.5 accu dll

android batterie einerschritte

xperia ray akku abfragen

energieanzeige windows xp registry

xperia neo akku zeigt immer voll an

xperia ray akkuanzeige

windowsmobile regedit akkustatus

wm6.5 akku anzeige in 1 schritten

xperia neo akkuanzeige immer leer

xperia akkuverbrauch anzeigen

xperia neo akkuanzeige problem

batterieanzeige windows xp regedit

Stichworte